Email Delivery Delayed
Incident Report for Condo Control Central
Resolved
This incident has been resolved.
Posted 12 days ago. Jan 08, 2019 - 12:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 12 days ago. Jan 08, 2019 - 12:05 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 12 days ago. Jan 08, 2019 - 10:40 EST
Investigating
We are currently investigating this issue.
Posted 12 days ago. Jan 08, 2019 - 10:30 EST
This incident affected: Outbound Email.