Chrome showing "Deceptive Site" warning
Incident Report for Condo Control Central
Postmortem

After investigating, we identified that Google had marked our site as “social engineering” or deceptive due to the large number of posts our clients have been publishing around the Covid-19 situation. They identified three posts in particular which they believed to be a scam.

As a result of this classification being applied to our site, visitors who went to the “Announcements” page in Chrome would see a red page saying that the site is a scam.

The use of aggressive keywords such as “strongly recommend”, “comply”, “public health authorities” etc, triggered Google’s monitoring systems to believe that our site was attempting to scam visitors.

We worked with our clients to revise the specified posts; we then reached out to Google, explained the situation, and requested they remove the classification from our site. By noon the situation was resolved.

We will be providing a blog post shortly to provide guidance to our clients on choosing the best wording to avoid problems in the future when writing about the current Covid-19 situation.

Posted Mar 25, 2020 - 15:24 EDT

Resolved
This incident has been resolved.
Posted Mar 25, 2020 - 11:02 EDT
Monitoring
Google has reviewed the wording and validated the messages as proper. The pages no longer show any error messages on chrome browser.

We will soon publish a guide on how to write emails about COVID -19 announcements.
Posted Mar 25, 2020 - 11:02 EDT
Identified
After investigating it appears that Google has marked the "Announcement" page on Condo Control Central as "social engineering" due to the numerous announcements our clients have posted regarding Covid-19. This is part of their broader effort to crack down on misinformation during this crisis.

We have contacted Google and are awaiting their response. We are requesting that they remove the "social engineering" flag from our site as all of the posts they identified are legitimate.

In the meantime until Google removes the flag - clients may click "Details" and "visit this unsafe site" to proceed with using CCC as normal.
Posted Mar 25, 2020 - 09:29 EDT
Investigating
We are currently investigating this issue and will provide more information as soon as we have an update. We are working to understand why google has flagged the announcement feature of Condo Control Central as deceptive or harmful.
Posted Mar 25, 2020 - 08:48 EDT
This incident affected: Web Application.