Support phone line issue
Incident Report for Condo Control Central
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 14:10 EDT
Investigating
Our phone provider is having issues today. Please note the best way to reach our support team is by email(contact@condocontrolcentral.com). We will call back as soon as the phone system issues are resolved.
Posted Mar 18, 2020 - 11:20 EDT