Issue reaching CCC support by email
Incident Report for Condo Control Central
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 13:19 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2020 - 13:07 EST
Identified
We are looking into an issue with users not able to reach Condo control support team by email. Please use the phone line in the mean time. We will add more updates soon.
Posted Nov 12, 2020 - 12:54 EST