Delayed Email Notifications
Incident Report for Condo Control Central
Resolved
The incident has been resolved. All backlogged emails have been sent.
Posted Nov 17, 2020 - 19:43 EST
Investigating
We are currently investigating this issue.
Posted Nov 17, 2020 - 14:47 EST
This incident affected: Outbound Email.